Setup

Thank you for purchasing EasySocial! In this section, you will learn on the pre-requisites that are required before you can install EasySocial on your site.

Zip Library

In order for the installation of EasySocial to commence, the PHP on the sever requires the zip module to be enabled or compiled with PHP. The reason is because we need to utilize the zip library to extract and decompressed the zip archives on the site.

Installing PHP Zip Library Using YUM (linux)

It is pretty easy to setup PHP with zip library on linux, since everything can be done using YUM. For those that are unfamiliar with YUM, they should start utilizing it now. You can learn more about YUM on WikiPedia.

Enabling PHP Zip Library (Windows)

To setup PHP with zip library on Microsoft Windows machines, you should only need to edit the php.ini file which is normally located at: C:\Windows\System32\php.ini. The folder may differ and you can find out the loaded php.ini configuration file via the PHP Information in Joomla.

Restart your IIS/Apache and you are good to go!

If you are unsure how to do this, it's best to contact your hosting provider for clarifications.