It's a weekend. Stay calm and enjoy.

It is currently a weekend from where we are at. If your client or employer requires you to work during the weekend, this would be a good read. Rest assured that we will get back to your posts as soon as the week starts!

Official support hours is from 10AM — 7PM Monday to Friday (GMT +8)

Hi Team,

I suggest to add "Inherit" to Komento's ACL in future (Feature Request). This is especially good for user's with multiple groups as not all group are for the purposes of controlling rights for the users (maybe membership, category access, etc) since EasyBlog's (and Komento) apply the "most restrictive rules" for ACL, then "Inherit" (or neutral) is required for the setting.

p.s. I will post the same feature request for EasyBlog.
Best regards,
Alfred / Dreamonde
7 replies
  • Mark replied on Saturday, May 10 2014, 03:18 PM
    Thanks for the heads up on this Alfred.
    Please do take some time to read through some of these links:

    http://stackideas.com/docs
    http://stackideas.com/support


    Our Social Media Pages:

    http://facebook.com/StackIdeas
    http://twitter.com/stackideas
  • Robert Young replied on Tuesday, September 30 2014, 03:20 AM
    I support this feature request. I like Komento but its ACL is not ideal on a site where users can belong to more than one group. Komento applies the most restrictive rule instead of allowing the user the permissions of his highest group, as in the Joomla! 3 ACL. Please do something about this.
  • NIK FARIS replied on Tuesday, September 30 2014, 10:11 AM
    Hello Robert,

    Thanks for writing in. Currently, our developers are focusing on EB5 and ES. We will see what we can do. :)
    Best regards,
    Nick
  • GARY MILLIDGE replied on Wednesday, April 06 2016, 01:06 AM
    Hi,

    Is it still the case that Komento does not fully support Joomla's ACL? I cannot get permissions to be applied correctly on my website. e.g.:

    I have a user who is a member of multiple groups. If I add him to a 'Super User' group (in Users), and have the Komento ACL setting for the Super User group to "Enable All", the user still cannot edit comments.

    Other users cannot 'like' comments, or reply to comments, even though their user profiles and Komento groups appear to be set up correctly.

    Am I missing something, or does Komento's ACL only work if users are members of one group suggested by Robert Young above?

    Many thanks!
  • Mark replied on Wednesday, April 06 2016, 11:59 AM
    Hey Gary,

    Currently the ACL still respects "deny" rule but in the next version of Komento, the "allow" rule will have higher precedence. In other words, regardless if which group the user is assigned to, as long as there is an "allow" rule, they will be allowed.
    Please do take some time to read through some of these links:

    http://stackideas.com/docs
    http://stackideas.com/support


    Our Social Media Pages:

    http://facebook.com/StackIdeas
    http://twitter.com/stackideas
  • GARY MILLIDGE replied on Wednesday, April 06 2016, 06:09 PM
    Many thanks for your speedy response! And it's encouraging to know that I won't have to move everything to a different system. Looking forward to the new version! Thanks again.
  • Muhammad Fadhli replied on Wednesday, April 06 2016, 06:20 PM
    You are most welcome.We appreciate your effort and feedback Gary! :)
    Best regards,
    Fadhli

    These links might come in handy.Please do take some time to read through some of these links:

    http://stackideas.com/docs
    http://stackideas.com/support


    Like and follow to our social media pages to know the latest update!:

    http://facebook.com/StackIdeas
    http://twitter.com/stackideas
Your time
Stack Ideas time
Support is
Offline
It's weekend!

It is currently a weekend from where we are at. Some answers may already be available on our documentation at http://stackideas.com/docs

Rest assured that we will get back to your posts as soon as the week starts!


Official support hour is:
Monday — Friday. 10:00 am - 7:00 pm
Our timezone:
Kuala Lumpur (GMT +8)