EasyArticles Stable Release

Joomla! 3.5 Updates

Joomla! 3.5 Updates

Joomla! 3.5 stable release will be released soon.

This update addresses:

  • PHP 7 support
  • Update emails plugin
  • Plugin to gather basic anonymized data as an opt-in feature
  • Count items
  • Added site and admin links to Module User Status
  • Ability to add a user CSS file to Protostar
  • Download system/environment information
  • TinyMCE drag and drop images

 

Why do I need to upgrade to Joomla! 3.5?

The latest version of our Joomla extensions now works out-of-the-box with Joomla 3.5 update. Due to the some changes in PHP 7, we would strongly advise our users to update their Joomla site to Joomla! 3.5 in order to avoid any unfavorable outcome. If you haven't done so yet, kindly do so as soon as possible. 

Read more about the announcement

 

Expired license subscriptions?

As I have mentioned earlier, we have tested all our of extensions and it works out-of-the-box with Joomla! 3.5. If you would like to renew your expired subscriptions, you may use the coupon code below to get 30% off any renewals. Don't wait 'cause this offer ends 19th March at 11:59 pm (Eastern time)

JOOMLA30

 

Changelog Renew Now

 

Joomla! 2.5 Support Ends

We would also like to take this opportunity to announce that we will no longer be supporting Joomla 2.5 sites by June 2016; as Joomla has already announced the end of life for Joomla 2.5 on 10th December 2014. This means Joomla! 2.5 will no longer receive any updates and no bugs or security issues will be fixed therefore Joomla! 2.5 will be unfit for use on live sites.

 

Comments (28)

It's good to see you have finally dropped support for Joomla 2.5, as having to supporting legacy code inhibits progress. I look forward to hearing more about EasyDiscuss 4 beta and any new version of EasySocial.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Randall McCallum

Thank you so much Randall We too are looking forward to those releases as well!

  Attachments
Your account does not have privileges to view attachments in the comment
 

<3

Yay for refocused support!

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    David Montoya

Yes, our team can now refocus our support! Thanks David!

  Attachments
Your account does not have privileges to view attachments in the comment
 

Dropping the support for an older stable version have nothing to do with limiting the progress as it does not imply that you have to carry the legacy code in new version of Joomla. It only said to owner of sites, difficult to pass to 3, Better chance next time! — Most of those next time will not be with Joomla but another CMS. We saw the result with 1.5.

  Attachments
Your account does not have privileges to view attachments in the comment
 

Hi Patrick,

It was a very difficult decision for us as well, but we have to move on as Joomla has already cease their support for J2.5 about a year ago.

  Attachments
Your account does not have privileges to view attachments in the comment
 

Hi Mark/Sylvie,

Thats good news. I had a question, would SI products (ES/EB/ED) support php7?
i.e would these comps take advantage of the advantages that php7 offers or would it rely on backward compatibility of php7 ?

rgds

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Sunny

Hi Sunny,

Our developers have tested all our components and I believe they are compatible with php7 and Joomla 3.5.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Sylvie

Hi Silvie,

Compatibility is not a major issue as most of it is backward compatible.

But would SI components take advantages of the performance advances in PHP7 ?

rgds

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Sunny

Until we officially drop support of Joomla 2.5 (Which will happen in June), we can't take advantage of this just yet.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Mark

I'm assuming this means on the code end as well? (It's obvious that the support end will drop for J 2.5) Less clutter code is good.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Mark

Yep, that is correct Josh Not only PHP but css as well. It's a nightmare trying to maintain CSS compatibility between Joomla 2.5 and Joomla 3.x

  Attachments
Your account does not have privileges to view attachments in the comment
 

Nice to see J! 3.5 will only call MooTools if something on the page needs it; how about EZ Blog? All jquery?

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Terp

Yep, we never relied on Mootools Entirely jQuery.

  Attachments
Your account does not have privileges to view attachments in the comment
 

Again lose the offer of renew for a few hours...
Any chance to extend the offer for a day more?

Thanks in advance!

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Emilio Navas

Hey Emilio,

Would you mind posting a ticket to https://crm.stackideas.com regarding this please? Thank you!

  Attachments
Your account does not have privileges to view attachments in the comment
 

Done!
Thanks Sylvie.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Emilio Navas

Thank you so much, Emilio

  Attachments
Your account does not have privileges to view attachments in the comment
 

The Joomla 3.5 update appeared later today. Install of update went smooth and everything appears to work with StackIdeas great extensions.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  Attachments
Your account does not have privileges to view attachments in the comment
 

Any estimate for the EasyDiscuss Beta or next test version? Hopefully soon!

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Randall McCallum

Hi Randall,

Sorry, I'm afraid we do not have a rough estimated time yet, but I believe Beta version will be out soon! *finger-crossed*

  Attachments
Your account does not have privileges to view attachments in the comment
 

Hi Guys,

For testing, i have installed an EasySocial 1.4.8 on a fresh joomla 3.5 installation. I have tried it twice. Unfortunatelly, after instlling EasySocial the frontend goes blank after successful installation, but the admin site works normally well.
Any idea why? I am running a VPS server on Ubuntu 14.04.

  Attachments
Your account does not have privileges to view attachments in the comment
 

Carlos,

I faced a similar issue with installing ES 1.4.8 and when I updated the Joomla Global setting Cache and then closed out of the browser, and then logged back in to the back-end of the administrator, everything that was an issue was cleared up. Give it a try. The StackIdeas team will be available during their hours of operation and they will assist you if this doesn't resolve the issues you are facing.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Randall McCallum

Thanks Randall. Tried but the front end is still blank. Any specific parameter you updated in Global setting Cache?

  Attachments
Your account does not have privileges to view attachments in the comment
  Comment was last edited about 1 year ago by Carlos Vasquez
  1.    Carlos Vasquez

This is the error message in Firefox console:

[HTTP/1.0 500 Internal Server Error 141ms]
The character encoding of the HTML document was not declared. The document will render with garbled text in some browser configurations if the document contains characters from outside the US-ASCII range. The character encoding of the page must be declared in the document or in the transfer protocol.

  Attachments
Your account does not have privileges to view attachments in the comment
 
  1.    Carlos Vasquez

Carlos,

Mark Lee, chief programmer at SI has indicate in a recent forum post that their ISP (Internet Service Provider) has had some issues. Perhaps by removing the installed version of ES 1.4.8 from the fresh install of 3.5 of Joomla, and then downloading a new installer and then reinstalling the ES 1.4.8 extension, it might hopefully resolve the issue.

Mark's recent forum post: Mark's post about ISP issues

Also, can you install another extension on the fresh install of Joomla 3.5 to...

Carlos,

Mark Lee, chief programmer at SI has indicate in a recent forum post that their ISP (Internet Service Provider) has had some issues. Perhaps by removing the installed version of ES 1.4.8 from the fresh install of 3.5 of Joomla, and then downloading a new installer and then reinstalling the ES 1.4.8 extension, it might hopefully resolve the issue.

Mark's recent forum post: Mark's post about ISP issues

Also, can you install another extension on the fresh install of Joomla 3.5 to make sure that there were no issues installing the Joomla 3.5 before installing ES 1.4.8? Sometimes there are issues that come up with FTP transfer downloads and then installs of Joomla.

Read More
  Attachments
Your account does not have privileges to view attachments in the comment
 

Hey Carlos,

Please submit a ticket so that we can take a look at the issues that you are facing

  Attachments
Your account does not have privileges to view attachments in the comment
 
There are no comments posted here yet

Subscribe To Our Blog

Subscribe to our blog by entering your email address:

Thanks! You have subscribed to our newsletter.

Some Updates On EasySocial 2.1

Friday, 28 July 2017 by Mark

Updates Available For All Products

Tuesday, 25 July 2017 by Sylvie

Introducing EasyArticles

Thursday, 25 May 2017 by Mark

Joomla 3.7.1 Security Release Available

Wednesday, 17 May 2017 by Mark

Echo Template Released

Tuesday, 24 January 2017 by Sylvie

ConverseKit 1.0.3

Friday, 20 January 2017 by Sylvie