Helpdesk

So my site is members only, so all menu items except the ones required login and register are set to the Registered Level. Similarly, users can only access 90% of the site if they have a valid subscription through payplans using the menuaccess app.
So when I log out or my session expires on one of these premium pages, I'm greeted with a log in page. So far so good. I log in and the site redirects me to the payplans component and gives the following error.

×Either you have not subscribed to any plan or your subscription has expired. Please subscribe to a plan to access this link.

This is incorrect, as trying to navigate back to that page that I was trying to access while logged out is accessible just fine as designed.
This interuption by payplans when there is a valid subscription could be very confusing to my users when they have a valid subcription. Perhaps they use bookmarks or just leave their computer open for too long and the site accuses them incorrectly of not having a valid subscription. Is there a solution to this?

This section can only be seen by users with a valid subscription.
If you have a valid subscription, please login now

Your time
Stack Ideas HQ
Support is
Offline

It is currently a weekend from where we are at. Some answers may already be available on our documentation

Rest assured that we will get back to your posts as soon as the week starts!

Buy Us Coffee

Are you happy with our support and would like to buy us a cup of coffee?

$
Enjoy the Coffee!
Service via PayPal
Subscribe for product updates & promotions