Well, that didn't take long. JUST bought a new version, tried to install the com_easyblog_launcher_pro_5.1.13_joomla.zip file on a Joomla 3.6.4 site and can't get pass step 2.
I searched your support, and there are a few entries suggesting this process is "automatic." Not so much, turns out.
This is the message I get with a red button whose only option is to contact support. Here's the message on step 2.
"This package doesn't contain a valid API key and it is most likely downloaded from an unauthorized source. Please do not proceed with the installation as it may tamper with your site."
Attachments (1)
Attachments can only be downloaded by logged in users

This section can only be seen by users with a valid subscription.
If you have a valid subscription, please login now

Support is
Online

The support team is online and will be able to answer your inquiries. Please stay calm, follow the rules and do not cross post.

We will attend to you as soon as we can.

Your time
Stack Ideas time