It appears there is only one way to disable "subscribe via rss".
Or it could be me, but I did try a few different ways.

Set categories to default off global entry layout settings.
Then went into views, layouts and disabled and it still showed.
Adjusted the menu item to hide and it still shows.
The only way it didn't show was when I disabled the entire RSS in General, RSS.
However, this disables for the entire site, correct?
Attachments (6)
Attachments can only be downloaded by logged in users

This section can only be seen by users with a valid subscription.
If you have a valid subscription, please login now

Support is
Online

The support team is online and will be able to answer your inquiries. Please stay calm, follow the rules and do not cross post.

We will attend to you as soon as we can.

Your time
Stack Ideas time