Module updates and more in EasyBlog 3.5 RC1

Module updates and more in EasyBlog 3.5 RC1

We are glad to announce the Release Candidate 1 (RC1) of EasyBlog 3.5 after some feedback from our users. We wanna thank all of you who did a great job responding to us.

What we worked on was some user interface issues and the workflow. You should be expecting better UX especially in the Media Manager!

If you are already using our range of plugins for JomSocial, yeah, we made them to be compatible with EasyBlog 3.5 too.

Two new modules have been added:

1. Post map module
You can now display a map in the module and add a marker on the map for blogs that are tagged with location. These markers will display the author's details, ratings and hits.

2. New Post module
This module makes you want to blog more! It shows a 'Write new post' button on the module for easy access to the EasyBlog dashboad to compose a new blog.

Some modules that are not included in 3.5:

1. Recent blog entries
2. Recent blog entries by blogger
3. Recent blog entries by category
4. Recent blog entries by tag

These modules are replaced with EasyBlog Latest Blogs module.

Ready to give EasyBlog another try? Download EasyBlog 3.5 RC1 now at our forums.

Edit: EasyBlog 3.5 RC 3 here.

 

Comments (16)

  1. renejdm

Hi,

Can I just install RC1 over top of 3.5 beta?

Rene

 
  1. Mark

Yep, that would work too :D

 
  1. Andy

...and if our (test) site still has the latest stable version of EB (in other words, not involved in any beta testing to date), what's the recommended upgrade path then? Is it still a uninstall of the existing EB first and then installing the RC1 version.

Congrats on another big push forwards towards Stable :)

 
  1. Mark

Hello Andy,

If you are using the beta, you can just install on top of the existing version as we have not updated our update servers yet :P

 
  1. Andy

What if I'm not using the Beta at all though? My test site currently still has EasyBlog Stable (sorry not been in a position to help with Beta testing :( but about to join in at this RC1 stage).... So if I'm going straight from an EasyBlog Stable to a RC1 what's the recommended route? Install on top of stable, or uninstall stable first?

 
  1. Mark

Hello Andy,

If you are from 3.0, it is also best to uninstall first and install 3.5 RC1 to ensure that the older files are no longer in the system. We've actually made quite a bit of modifications on the files so it's best to have a clean environment first (If you did not perform any hacks that is)

 
  1. Richard Bankert

That's awesome. Very much enjoying the updates :)

 
  1. Jack

Thank you Richard :D

 
  1. Phillip R Jorgensen

Might I ask why you guys don't spend more time on validation? I mean 145 errors and 18 warnings just on this blog alone. I purchased easy blog and I think it's a great component but the lack of validation is something that is very concerning to me.
I realized these things after purchases of easyblog and jomsocial. Neither of these components validate. With joomla 2.5 making a blog is fairly simple and it validates easily.
Without validation it's tough to try to build sites for others using...

Might I ask why you guys don't spend more time on validation? I mean 145 errors and 18 warnings just on this blog alone. I purchased easy blog and I think it's a great component but the lack of validation is something that is very concerning to me.
I realized these things after purchases of easyblog and jomsocial. Neither of these components validate. With joomla 2.5 making a blog is fairly simple and it validates easily.
Without validation it's tough to try to build sites for others using this component.

This component is to good to be removed from my buy list because of this issue.

Read More
 
  1. Jack

Hey Phillip,

Are you referring to the W3C validations? What sort of errors are you getting there? In EasyBlog 3.5 we have implemented Google's rich snippet which is html5 compliant and I am not too sure if W3C validation would pass that but

Furthermore, Facebook uses it's own set of markup language and I would highly doubt that it would validate or play along nicely with W3C's validation service.

Nevertheless, we are always open for suggestion and ideas. If you have any suggestions, feel...

Hey Phillip,

Are you referring to the W3C validations? What sort of errors are you getting there? In EasyBlog 3.5 we have implemented Google's rich snippet which is html5 compliant and I am not too sure if W3C validation would pass that but

Furthermore, Facebook uses it's own set of markup language and I would highly doubt that it would validate or play along nicely with W3C's validation service.

Nevertheless, we are always open for suggestion and ideas. If you have any suggestions, feel free to post them in our forum :D

Read More
 
  1. US Joomla Force

Thank you andrew rogers for hearing the suggestions of users and implementing it. All the best..

 
  1. Alex

Can be get a heads up as to when this will come out of BETA and be ready for live.

Regards

 
  1. Mark

Alex, another release candidate will be available shortly and once everything is stable, we'll be releasing a stable release :D

 
  1. Alex

Ok great.

Thanks for the heads up :)

 
  1. Jack Poore II

Hey, I have major issues with the showcase module working. Do you have any ideas of what this could be. It totally just takes over the whole page the page turns white with just the showcase at the very top.

 
  1. Mark

Hello Jack,

Can you please submit issues in the forum instead of the comments here :D

 
There are no comments posted here yet